aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2016-06-21 19:51:34 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2016-06-21 19:51:34 +0300
commitbe612cbab27967afcc60175ce78ea88b7108659e (patch)
treeb7715ddd869bb14e4492e4b0fafadc52886da7de /CMakeLists.txt
parentREADME updates (diff)
downloadaes-tools-be612cbab27967afcc60175ce78ea88b7108659e.tar.gz
aes-tools-be612cbab27967afcc60175ce78ea88b7108659e.zip
fix GCC errors
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 57398a2..1c16efd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,15 +1,24 @@
-project(aes_tools C CXX ASM_MASM)
+project(aes_tools)
file(GLOB_RECURSE libaes_headers "include/*.h")
+
if(LIBAES_USE_ASM)
+ enable_language(ASM_MASM)
+
file(GLOB libaes_c_sources "src/*.c")
file(GLOB libaes_asm_sources "src/asm/*.asm")
+
set(libaes_sources ${libaes_asm_sources} ${libaes_c_sources})
set_source_files_properties(${libaes_asm_sources} PROPERTIES COMPILE_FLAGS "/safeseh")
# Setting CMAKE_ASM_MASM_FLAGS doesn't work: http://www.cmake.org/Bug/view.php?id=14711
else()
file(GLOB_RECURSE libaes_sources "src/*.c")
endif()
+
+if(CMAKE_COMPILER_IS_GNUCC)
+ add_compile_options(-mssse3 -maes)
+endif()
+
add_library(libaes ${libaes_sources} ${libaes_headers})
target_include_directories(libaes PUBLIC include/)
target_compile_definitions(libaes PRIVATE _CRT_SECURE_NO_WARNINGS)