aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2017-02-08 03:22:18 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2017-02-08 03:22:18 +0300
commit6efde574b8442cf3717b21ffa1434a181d7b6296 (patch)
tree5d0abdcea46583cd7c7d1f33919de622c617be5a /CMakeLists.txt
parenttest: code style (diff)
downloadaes-tools-6efde574b8442cf3717b21ffa1434a181d7b6296.tar.gz
aes-tools-6efde574b8442cf3717b21ffa1434a181d7b6296.zip
CMakeLists.txt updates
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt68
1 files changed, 45 insertions, 23 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8d3a6c8..2eed01d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,50 +1,67 @@
project(aes_tools)
-if(MSVC)
- add_compile_options(/MP /W4)
-elseif(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)
- add_compile_options(-Wall -Wextra)
-endif()
-
get_directory_property(parent_directory PARENT_DIRECTORY)
set(is_root_project $<NOT:parent_directory>)
+set(AES_TOOLS_USE_STATIC_RUNTIME "${is_root_project}" CACHE BOOL "Link the runtime statically")
+set(AES_TOOLS_STRIP_SYMBOL_TABLE "${is_root_project}" CACHE BOOL "Strip symbol tables")
+
+set(AES_TOOLS_ASM OFF CACHE BOOL "Use the assembly language implementation instead of the one in C")
+
+if(is_root_project)
+ if(MSVC)
+ add_compile_options(/MP /W4)
+ elseif(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)
+ add_compile_options(-Wall -Wextra)
+ endif()
+endif()
+
function(use_static_runtime_msvc target)
- target_compile_options(${target} PRIVATE
+ target_compile_options("${target}" PRIVATE
$<$<CONFIG:Debug>:/MTd>
- $<$<CONFIG:Release>:/MT>)
+ $<$<NOT:$<CONFIG:Debug>>:/MT>)
endfunction()
function(use_static_runtime_gcc target)
- get_target_property(type ${target} TYPE)
- if(type STREQUAL EXECUTABLE)
- target_link_libraries(${target} PRIVATE -static)
+ get_target_property(target_type "${target}" TYPE)
+ if(target_type STREQUAL EXECUTABLE)
+ target_link_libraries("${target}" PRIVATE -static)
endif()
endfunction()
function(use_static_runtime target)
if(MSVC)
- use_static_runtime_msvc(${target})
+ use_static_runtime_msvc("${target}")
elseif(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)
- use_static_runtime_gcc(${target})
+ use_static_runtime_gcc("${target}")
+ else()
+ message(WARNING "Unrecognized toolset")
endif()
endfunction()
function(strip_symbol_table_gcc target)
- target_link_libraries(${target} PRIVATE $<$<CONFIG:Release>:-s>)
+ target_link_libraries("${target}" PRIVATE
+ $<$<OR:$<CONFIG:Release>,$<CONFIG:MinSizeRel>>:-s>)
endfunction()
function(strip_symbol_table target)
- if(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)
- strip_symbol_table_gcc(${target})
+ if(MSVC)
+ elseif(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)
+ strip_symbol_table_gcc("${target}")
+ else()
+ message(WARNING "Unrecognized toolset")
endif()
endfunction()
macro(add_executable target)
_add_executable(${ARGV})
- if(TARGET ${target} AND is_root_project)
- use_static_runtime(${target})
- strip_symbol_table(${target})
+ if(TARGET "${target}")
+ if(AES_TOOLS_USE_STATIC_RUNTIME)
+ use_static_runtime("${target}")
+ endif()
+ if(AES_TOOLS_STRIP_SYMBOL_TABLE)
+ strip_symbol_table("${target}")
+ endif()
endif()
endmacro()
@@ -55,7 +72,7 @@ if(MSVC AND AES_TOOLS_ASM)
file(GLOB libaes_c_sources "src/*.c")
file(GLOB libaes_asm_sources "src/asm/*.asm")
set(libaes_sources ${libaes_asm_sources} ${libaes_c_sources})
- set_source_files_properties(${libaes_asm_sources} PROPERTIES COMPILE_FLAGS "/safeseh")
+ set_source_files_properties(${libaes_asm_sources} PROPERTIES COMPILE_FLAGS /safeseh)
# Setting CMAKE_ASM_MASM_FLAGS doesn't work: http://www.cmake.org/Bug/view.php?id=14711
else()
file(GLOB_RECURSE libaes_sources "src/*.c")
@@ -63,10 +80,15 @@ endif()
add_library(libaes ${libaes_sources} ${libaes_headers})
target_include_directories(libaes PUBLIC include/)
-use_static_runtime(libaes)
-if(MSVC)
- target_compile_definitions(libaes PRIVATE _CRT_SECURE_NO_WARNINGS)
+if(AES_TOOLS_USE_STATIC_RUNTIME)
+ use_static_runtime(libaes)
+endif()
+
+if(is_root_project)
+ if(MSVC)
+ target_compile_definitions(libaes PRIVATE _CRT_SECURE_NO_WARNINGS)
+ endif()
endif()
if(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)