aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/cxx/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2015-08-23 04:04:36 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2015-08-23 04:04:36 +0300
commit44c190064c0e52fcdb8db0906056b2bd6f46d306 (patch)
treeb10ef3aa6d91875d7eae08e6c3e4d68ab0d4f4fe /cxx/CMakeLists.txt
parentbugfix (diff)
downloadaes-tools-44c190064c0e52fcdb8db0906056b2bd6f46d306.tar.gz
aes-tools-44c190064c0e52fcdb8db0906056b2bd6f46d306.zip
cxx: Boost.Config for compiler workarounds
Diffstat (limited to '')
-rw-r--r--cxx/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/cxx/CMakeLists.txt b/cxx/CMakeLists.txt
index 14b7700..71173b5 100644
--- a/cxx/CMakeLists.txt
+++ b/cxx/CMakeLists.txt
@@ -1,3 +1,5 @@
+find_package(Boost REQUIRED)
+
add_library(libaesnixx INTERFACE)
-target_include_directories(libaesnixx INTERFACE include/)
+target_include_directories(libaesnixx INTERFACE include/ ${Boost_INCLUDE_DIRS})
target_link_libraries(libaesnixx INTERFACE libaesni)