aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2015-06-04 06:14:35 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2015-06-04 06:14:35 +0300
commit09c2543e905ddd2915e628b0e2c0c7e9c596f2bb (patch)
treee0a860c3b22d3233ef2d762275e91f2eabc448bd /examples/CMakeLists.txt
parentgrammar tweaks (diff)
downloadaes-tools-09c2543e905ddd2915e628b0e2c0c7e9c596f2bb.tar.gz
aes-tools-09c2543e905ddd2915e628b0e2c0c7e9c596f2bb.zip
remove redundant file suffixes
Diffstat (limited to '')
-rw-r--r--examples/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index db2b2c4..8cf4d6a 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -1,8 +1,9 @@
set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /SAFESEH:NO")
macro(example prefix)
- add_executable(${prefix}_example ${prefix}_example.c)
- target_link_libraries(${prefix}_example libaesni)
+ add_executable(example_${prefix} ${prefix}.c)
+ target_link_libraries(example_${prefix} libaesni)
+ set_target_properties(example_${prefix} PROPERTIES OUTPUT_NAME ${prefix})
endmacro()
example(aes128ecb)