aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2015-06-04 06:14:35 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2015-06-04 06:14:35 +0300
commit09c2543e905ddd2915e628b0e2c0c7e9c596f2bb (patch)
treee0a860c3b22d3233ef2d762275e91f2eabc448bd /test/CMakeLists.txt
parentgrammar tweaks (diff)
downloadaes-tools-09c2543e905ddd2915e628b0e2c0c7e9c596f2bb.tar.gz
aes-tools-09c2543e905ddd2915e628b0e2c0c7e9c596f2bb.zip
remove redundant file suffixes
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index f4460f0..a024d40 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,11 +1,13 @@
set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /SAFESEH:NO")
macro(test prefix)
- add_executable(${prefix}_encrypt_block ${prefix}_encrypt_block.c)
- target_link_libraries(${prefix}_encrypt_block libaesni)
+ add_executable(test_${prefix}_encrypt ${prefix}_encrypt.c)
+ target_link_libraries(test_${prefix}_encrypt libaesni)
+ set_target_properties(test_${prefix}_encrypt PROPERTIES OUTPUT_NAME ${prefix}_encrypt)
- add_executable(${prefix}_decrypt_block ${prefix}_decrypt_block.c)
- target_link_libraries(${prefix}_decrypt_block libaesni)
+ add_executable(test_${prefix}_decrypt ${prefix}_decrypt.c)
+ target_link_libraries(test_${prefix}_decrypt libaesni)
+ set_target_properties(test_${prefix}_decrypt PROPERTIES OUTPUT_NAME ${prefix}_decrypt)
endmacro()
test(aes128ecb)