aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2015-06-20 17:19:37 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2015-06-20 17:19:37 +0300
commit376316d110433ab4f15975c57d0f122aa265f588 (patch)
treebf326f77930cfa6b8e1eba585cfe2159f5351b5b /utils/CMakeLists.txt
parenttest: better error handling in block utils (diff)
downloadaes-tools-376316d110433ab4f15975c57d0f122aa265f588.tar.gz
aes-tools-376316d110433ab4f15975c57d0f122aa265f588.zip
utils: add bitmap utils
Diffstat (limited to '')
-rw-r--r--utils/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/utils/CMakeLists.txt b/utils/CMakeLists.txt
index 110aa7e..d13bdeb 100644
--- a/utils/CMakeLists.txt
+++ b/utils/CMakeLists.txt
@@ -18,3 +18,13 @@ add_executable(util_aes_decrypt_file aes_decrypt_file.cpp aes_common.hpp)
target_include_directories(util_aes_decrypt_file PRIVATE ${Boost_INCLUDE_DIRS})
target_link_libraries(util_aes_decrypt_file libaesni libaesnixx ${Boost_LIBRARIES})
set_target_properties(util_aes_decrypt_file PROPERTIES OUTPUT_NAME aes_decrypt_file)
+
+add_executable(util_aes_encrypt_bmp aes_encrypt_bmp.cpp aes_common.hpp)
+target_include_directories(util_aes_encrypt_bmp PRIVATE ${Boost_INCLUDE_DIRS})
+target_link_libraries(util_aes_encrypt_bmp libaesni libaesnixx ${Boost_LIBRARIES})
+set_target_properties(util_aes_encrypt_bmp PROPERTIES OUTPUT_NAME aes_encrypt_bmp)
+
+add_executable(util_aes_decrypt_bmp aes_decrypt_bmp.cpp aes_common.hpp)
+target_include_directories(util_aes_decrypt_bmp PRIVATE ${Boost_INCLUDE_DIRS})
+target_link_libraries(util_aes_decrypt_bmp libaesni libaesnixx ${Boost_LIBRARIES})
+set_target_properties(util_aes_decrypt_bmp PROPERTIES OUTPUT_NAME aes_decrypt_bmp)