aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/utils/block/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2015-06-24 05:59:11 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2015-06-24 05:59:11 +0300
commit225ef13cc7f58b69ef4c4db6308a225c726359f7 (patch)
tree75454aa3d5b4042ddacbf22ddab2680c47caf405 /utils/block/CMakeLists.txt
parenttest: locate executables in PATH (diff)
downloadaes-tools-225ef13cc7f58b69ef4c4db6308a225c726359f7.tar.gz
aes-tools-225ef13cc7f58b69ef4c4db6308a225c726359f7.zip
move executables from test/ to utils/
Diffstat (limited to 'utils/block/CMakeLists.txt')
-rw-r--r--utils/block/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/utils/block/CMakeLists.txt b/utils/block/CMakeLists.txt
new file mode 100644
index 0000000..4b232bd
--- /dev/null
+++ b/utils/block/CMakeLists.txt
@@ -0,0 +1,27 @@
+macro(util prefix)
+ add_executable(util_${prefix}_encrypt_block ${prefix}_encrypt_block.c)
+ target_link_libraries(util_${prefix}_encrypt_block libaesni)
+ set_target_properties(util_${prefix}_encrypt_block PROPERTIES OUTPUT_NAME ${prefix}_encrypt_block)
+
+ add_executable(util_${prefix}_decrypt_block ${prefix}_decrypt_block.c)
+ target_link_libraries(util_${prefix}_decrypt_block libaesni)
+ set_target_properties(util_${prefix}_decrypt_block PROPERTIES OUTPUT_NAME ${prefix}_decrypt_block)
+endmacro()
+
+util(aes128ecb)
+util(aes128cbc)
+util(aes128cfb)
+util(aes128ofb)
+util(aes128ctr)
+util(aes192ecb)
+util(aes192cbc)
+util(aes192cfb)
+util(aes192ofb)
+util(aes192ctr)
+util(aes256ecb)
+util(aes256cbc)
+util(aes256cfb)
+util(aes256ofb)
+util(aes256ctr)
+
+add_subdirectory(cxx)