aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/utils/file/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2015-06-24 05:59:11 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2015-06-24 05:59:11 +0300
commit225ef13cc7f58b69ef4c4db6308a225c726359f7 (patch)
tree75454aa3d5b4042ddacbf22ddab2680c47caf405 /utils/file/CMakeLists.txt
parenttest: locate executables in PATH (diff)
downloadaes-tools-225ef13cc7f58b69ef4c4db6308a225c726359f7.tar.gz
aes-tools-225ef13cc7f58b69ef4c4db6308a225c726359f7.zip
move executables from test/ to utils/
Diffstat (limited to '')
-rw-r--r--utils/file/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/utils/file/CMakeLists.txt b/utils/file/CMakeLists.txt
new file mode 100644
index 0000000..ad949f7
--- /dev/null
+++ b/utils/file/CMakeLists.txt
@@ -0,0 +1,10 @@
+macro(util prefix)
+ add_executable(util_${prefix} ${prefix}.cpp)
+ target_link_libraries(util_${prefix} libaesnixx libaesni)
+ set_target_properties(util_${prefix} PROPERTIES OUTPUT_NAME ${prefix})
+endmacro()
+
+util(aes128ecb_encrypt_file)
+util(aes128ecb_decrypt_file)
+
+add_subdirectory(cxx)