aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/utils/file/cxx/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2015-06-25 01:18:24 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2015-06-25 01:18:24 +0300
commitf752dfe56b67f2729df0c54c83612ba36f8133bc (patch)
tree9d392157a1d9ae0d112260c5dedc7ec535d38291 /utils/file/cxx/CMakeLists.txt
parentcxx: implement more stuff (diff)
downloadaes-tools-f752dfe56b67f2729df0c54c83612ba36f8133bc.tar.gz
aes-tools-f752dfe56b67f2729df0c54c83612ba36f8133bc.zip
remove specialized buffer encryption functions
Diffstat (limited to '')
-rw-r--r--utils/file/cxx/CMakeLists.txt21
1 files changed, 0 insertions, 21 deletions
diff --git a/utils/file/cxx/CMakeLists.txt b/utils/file/cxx/CMakeLists.txt
deleted file mode 100644
index 75895a0..0000000
--- a/utils/file/cxx/CMakeLists.txt
+++ /dev/null
@@ -1,21 +0,0 @@
-find_package(Boost REQUIRED COMPONENTS program_options)
-
-add_executable(util_aes_encrypt_file aes_encrypt_file.cpp aes_common.hpp)
-target_include_directories(util_aes_encrypt_file PRIVATE ${Boost_INCLUDE_DIRS})
-target_link_libraries(util_aes_encrypt_file libaesni libaesnixx ${Boost_LIBRARIES})
-set_target_properties(util_aes_encrypt_file PROPERTIES OUTPUT_NAME aes_encrypt_file)
-
-add_executable(util_aes_decrypt_file aes_decrypt_file.cpp aes_common.hpp)
-target_include_directories(util_aes_decrypt_file PRIVATE ${Boost_INCLUDE_DIRS})
-target_link_libraries(util_aes_decrypt_file libaesni libaesnixx ${Boost_LIBRARIES})
-set_target_properties(util_aes_decrypt_file PROPERTIES OUTPUT_NAME aes_decrypt_file)
-
-add_executable(util_aes_encrypt_bmp aes_encrypt_bmp.cpp aes_common.hpp)
-target_include_directories(util_aes_encrypt_bmp PRIVATE ${Boost_INCLUDE_DIRS})
-target_link_libraries(util_aes_encrypt_bmp libaesni libaesnixx ${Boost_LIBRARIES})
-set_target_properties(util_aes_encrypt_bmp PROPERTIES OUTPUT_NAME aes_encrypt_bmp)
-
-add_executable(util_aes_decrypt_bmp aes_decrypt_bmp.cpp aes_common.hpp)
-target_include_directories(util_aes_decrypt_bmp PRIVATE ${Boost_INCLUDE_DIRS})
-target_link_libraries(util_aes_decrypt_bmp libaesni libaesnixx ${Boost_LIBRARIES})
-set_target_properties(util_aes_decrypt_bmp PROPERTIES OUTPUT_NAME aes_decrypt_bmp)