aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/aesxx/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'aesxx/CMakeLists.txt')
-rw-r--r--aesxx/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/aesxx/CMakeLists.txt b/aesxx/CMakeLists.txt
new file mode 100644
index 0000000..9bbf777
--- /dev/null
+++ b/aesxx/CMakeLists.txt
@@ -0,0 +1,13 @@
+find_package(Boost REQUIRED)
+
+add_library(aesxx INTERFACE)
+target_include_directories(aesxx INTERFACE include/)
+target_link_libraries(aesxx INTERFACE aes Boost::boost)
+
+if(MSVC_VERSION EQUAL 1900)
+ # These annoying DbgHelp.h warnings:
+ # https://connect.microsoft.com/VisualStudio/feedback/details/888527/warnings-on-dbghelp-h
+ target_compile_options(aesxx INTERFACE /wd4091)
+endif()
+
+install(DIRECTORY include/aesxx DESTINATION include)