aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/cxx/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'cxx/CMakeLists.txt')
-rw-r--r--cxx/CMakeLists.txt13
1 files changed, 0 insertions, 13 deletions
diff --git a/cxx/CMakeLists.txt b/cxx/CMakeLists.txt
deleted file mode 100644
index 9bbf777..0000000
--- a/cxx/CMakeLists.txt
+++ /dev/null
@@ -1,13 +0,0 @@
-find_package(Boost REQUIRED)
-
-add_library(aesxx INTERFACE)
-target_include_directories(aesxx INTERFACE include/)
-target_link_libraries(aesxx INTERFACE aes Boost::boost)
-
-if(MSVC_VERSION EQUAL 1900)
- # These annoying DbgHelp.h warnings:
- # https://connect.microsoft.com/VisualStudio/feedback/details/888527/warnings-on-dbghelp-h
- target_compile_options(aesxx INTERFACE /wd4091)
-endif()
-
-install(DIRECTORY include/aesxx DESTINATION include)