aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/cxx/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'cxx/CMakeLists.txt')
-rw-r--r--cxx/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/cxx/CMakeLists.txt b/cxx/CMakeLists.txt
index 418f004..97cb9a5 100644
--- a/cxx/CMakeLists.txt
+++ b/cxx/CMakeLists.txt
@@ -3,3 +3,7 @@ find_package(Boost REQUIRED)
add_library(libaesxx INTERFACE)
target_include_directories(libaesxx INTERFACE include/ ${Boost_INCLUDE_DIRS})
target_link_libraries(libaesxx INTERFACE libaes)
+
+if(CMAKE_COMPILER_IS_GNUCC)
+ target_compile_options(libaesxx INTERFACE -std=c++11)
+endif()