aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 199388d..0ee556f 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,3 +1,29 @@
+macro(test prefix)
+ add_executable(test_${prefix}_encrypt_block ${prefix}_encrypt_block.c)
+ target_link_libraries(test_${prefix}_encrypt_block libaesni)
+ set_target_properties(test_${prefix}_encrypt_block PROPERTIES OUTPUT_NAME ${prefix}_encrypt_block)
+
+ add_executable(test_${prefix}_decrypt_block ${prefix}_decrypt_block.c)
+ target_link_libraries(test_${prefix}_decrypt_block libaesni)
+ set_target_properties(test_${prefix}_decrypt_block PROPERTIES OUTPUT_NAME ${prefix}_decrypt_block)
+endmacro()
+
+test(aes128ecb)
+test(aes128cbc)
+test(aes128cfb)
+test(aes128ofb)
+test(aes128ctr)
+test(aes192ecb)
+test(aes192cbc)
+test(aes192cfb)
+test(aes192ofb)
+test(aes192ctr)
+test(aes256ecb)
+test(aes256cbc)
+test(aes256cfb)
+test(aes256ofb)
+test(aes256ctr)
+
find_package(Boost REQUIRED COMPONENTS program_options)
add_executable(test_encrypt_block_aes encrypt_block_aes.cpp common_aes.hpp)