aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2023-06-30 02:37:27 +0200
committerEgor Tensin <Egor.Tensin@gmail.com>2023-06-30 03:32:14 +0200
commite928ce51bd8c26742abfd537b054483a18a9689c (patch)
treead3bfcf7b509dbde4681c011237c8bd23ee8583f /CMakeLists.txt
parentfix function names in error messages (diff)
downloadcimple-e928ce51bd8c26742abfd537b054483a18a9689c.tar.gz
cimple-e928ce51bd8c26742abfd537b054483a18a9689c.zip
show git hash with --version
Also, use cmake's configure_file to build string constants in.
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 848890d..95f423e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 3.3) # for include-what-you-use
+cmake_minimum_required(VERSION 3.19) # for COMMAND_ERROR_IS_FATAL
project(cimple VERSION 0.0.1 LANGUAGES C)