aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 10c7066..c647937 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -8,6 +8,9 @@ add_compile_definitions(_GNU_SOURCE)
add_compile_definitions(VERSION="${PROJECT_VERSION}")
+set(DEFAULT_HOST "127.0.0.1" CACHE STRING "Set the default --host value")
+add_compile_definitions(DEFAULT_HOST="${DEFAULT_HOST}")
+
function(add_my_executable name)
list(POP_FRONT ARGV)
add_executable("${name}" ${ARGV})