aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 326a50b..18b49be 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -2,23 +2,23 @@ find_package(Python3 REQUIRED COMPONENTS Interpreter)
set(python_test_args
--no-header -v
- "${CMAKE_CURRENT_SOURCE_DIR}"
+ "${CMAKE_CURRENT_SOURCE_DIR}/py"
--server-binary "$<TARGET_FILE:server>"
--worker-binary "$<TARGET_FILE:worker>"
--client-binary "$<TARGET_FILE:client>"
--project-version "${PROJECT_VERSION}")
-function(add_my_test name)
+function(add_python_tests name)
list(POP_FRONT ARGV)
add_test(NAME "${name}"
- WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}"
+ WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/py"
COMMAND ${ARGV})
set_tests_properties("${name}" PROPERTIES TIMEOUT 60)
endfunction()
-add_my_test(python_tests
+add_python_tests(python_tests
Python3::Interpreter -m pytest ${python_test_args})
-add_my_test(python_tests_valgrind
+add_python_tests(python_tests_valgrind
Python3::Interpreter -m pytest ${python_test_args}
--valgrind-binary "${CMAKE_CURRENT_SOURCE_DIR}/../src/valgrind.sh")