aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/Makefile
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2023-06-30 23:09:00 +0200
committerEgor Tensin <Egor.Tensin@gmail.com>2023-06-30 23:09:00 +0200
commit8803f2a91780c4df6fa62f740f4cd128755cf8d1 (patch)
tree06455164a890218744cc7b1e14c8ca737ae3037a /Makefile
parentMakefile: fix macOS builds (diff)
downloadcmake-common-8803f2a91780c4df6fa62f740f4cd128755cf8d1.tar.gz
cmake-common-8803f2a91780c4df6fa62f740f4cd128755cf8d1.zip
Makefile: move the prelude to prelude.mk
Diffstat (limited to '')
-rw-r--r--Makefile22
1 files changed, 1 insertions, 21 deletions
diff --git a/Makefile b/Makefile
index 458acbf..361f610 100644
--- a/Makefile
+++ b/Makefile
@@ -1,24 +1,4 @@
-MAKEFLAGS += --no-builtin-rules --no-builtin-variables --warn-undefined-variables
-unexport MAKEFLAGS
-.DEFAULT_GOAL := all
-.DELETE_ON_ERROR:
-.SUFFIXES:
-SHELL := bash
-.SHELLFLAGS := -eu -o pipefail -c
-
-escape = $(subst ','\'',$(1))
-
-define noexpand
-ifeq ($$(origin $(1)),environment)
- $(1) := $$(value $(1))
-endif
-ifeq ($$(origin $(1)),environment override)
- $(1) := $$(value $(1))
-endif
-ifeq ($$(origin $(1)),command line)
- override $(1) := $$(value $(1))
-endif
-endef
+include prelude.mk
PKG_NAME := cmake-common