aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/Makefile
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2023-01-08 16:06:34 +0100
committerEgor Tensin <Egor.Tensin@gmail.com>2023-01-08 16:18:07 +0100
commit434d34138cdfe2db377efbdc2e6c8bb55d9e88a3 (patch)
treedec68366a892329fd1610e94f5a1f24456c97e3d /Makefile
downloadcmake-common-434d34138cdfe2db377efbdc2e6c8bb55d9e88a3.tar.gz
cmake-common-434d34138cdfe2db377efbdc2e6c8bb55d9e88a3.zip
add AUR package files
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..08c7500
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,44 @@
+MAKEFLAGS += --no-builtin-rules --no-builtin-variables --warn-undefined-variables
+unexport MAKEFLAGS
+.DEFAULT_GOAL := all
+.DELETE_ON_ERROR:
+.SUFFIXES:
+SHELL := bash
+.SHELLFLAGS := -eu -o pipefail -c
+
+escape = $(subst ','\'',$(1))
+
+define noexpand
+ifeq ($$(origin $(1)),environment)
+ $(1) := $$(value $(1))
+endif
+ifeq ($$(origin $(1)),environment override)
+ $(1) := $$(value $(1))
+endif
+ifeq ($$(origin $(1)),command line)
+ override $(1) := $$(value $(1))
+endif
+endef
+
+PKG_NAME := cmake-common
+
+this_dir := $(dir $(realpath $(firstword $(MAKEFILE_LIST))))
+
+.PHONY: all
+all: package
+
+.PHONY: package
+package:
+ makepkg --clean --cleanbuild --force --syncdeps && makepkg --printsrcinfo > '$(call escape,$(this_dir))/.SRCINFO'
+
+.PHONY: commit
+commit:
+ source PKGBUILD && git commit -am "aur: $$pkgver-$$pkgrel"
+
+.PHONY: push
+push:
+ git push 'ssh://aur@aur.archlinux.org/$(call escape,$(PKG_NAME)).git' "$$( git symbolic-ref HEAD ):master"
+
+.PHONY: clean
+clean:
+ find '$(call escape,$(this_dir))' -type f '-(' -name '*.tar.gz' -o -name '*.tar.zst' '-)' -delete