aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/cmake/examples/boost/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-03-28 17:19:43 +0000
committerEgor Tensin <Egor.Tensin@gmail.com>2020-03-28 17:23:15 +0000
commit70da99e4f70845da37ae368c4788ecc18546792d (patch)
tree51f50290e2ea926350c88fa5fa0e8d4d2ad426fa /cmake/examples/boost/CMakeLists.txt
parentcommon.cmake: account for ALIAS targets (diff)
downloadcmake-common-70da99e4f70845da37ae368c4788ecc18546792d.tar.gz
cmake-common-70da99e4f70845da37ae368c4788ecc18546792d.zip
WIP: restructure
A stupid attempt to reduce code duplication led me to believe that all the scripts could use _a bit_ of refactoring. This is going to be a major pain (factoring out all the things), which I'll take gladly. All the links and usage examples are broken right now, but nobody cares, so whatevs.
Diffstat (limited to 'cmake/examples/boost/CMakeLists.txt')
-rw-r--r--cmake/examples/boost/CMakeLists.txt14
1 files changed, 0 insertions, 14 deletions
diff --git a/cmake/examples/boost/CMakeLists.txt b/cmake/examples/boost/CMakeLists.txt
deleted file mode 100644
index 8c076c9..0000000
--- a/cmake/examples/boost/CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
-cmake_minimum_required(VERSION 3.5) # for Boost::* imported targets
-
-project(example_boost)
-
-include(../../common.cmake)
-
-find_package(Boost REQUIRED COMPONENTS filesystem)
-add_executable(foo foo.cpp)
-target_link_libraries(foo PRIVATE Boost::disable_autolinking Boost::filesystem)
-
-install(TARGETS foo RUNTIME DESTINATION bin)
-if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
- install(FILES "$<TARGET_PDB_FILE:foo>" DESTINATION bin OPTIONAL)
-endif()