aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/cmake/examples/dynamic/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-01-07 03:26:04 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2020-01-07 03:26:04 +0300
commita2bc2333b474adfde66c6cd67315f227491f157c (patch)
treeec649e03f10e14f92258e68a1ecbe81febca2af3 /cmake/examples/dynamic/CMakeLists.txt
parentcmake/build: remove the --clean parameter (diff)
downloadcmake-common-a2bc2333b474adfde66c6cd67315f227491f157c.tar.gz
cmake-common-a2bc2333b474adfde66c6cd67315f227491f157c.zip
cmake: add examples
Diffstat (limited to 'cmake/examples/dynamic/CMakeLists.txt')
-rw-r--r--cmake/examples/dynamic/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/cmake/examples/dynamic/CMakeLists.txt b/cmake/examples/dynamic/CMakeLists.txt
new file mode 100644
index 0000000..013cde1
--- /dev/null
+++ b/cmake/examples/dynamic/CMakeLists.txt
@@ -0,0 +1,13 @@
+cmake_minimum_required(VERSION 3.1)
+
+project(example_dynamic)
+
+include(../../common.cmake)
+
+add_library(bar SHARED bar.cpp)
+target_include_directories(bar PUBLIC .)
+
+add_executable(foo foo.cpp)
+target_link_libraries(foo PRIVATE bar)
+
+install(TARGETS foo bar RUNTIME DESTINATION bin LIBRARY DESTINATION lib)