aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/cmake/examples/dynamic/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-01-17 23:53:16 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2020-01-18 00:16:22 +0300
commit99eb9822b4dfa67f65674eac92f1371dc4be9d31 (patch)
tree47fc1f817c805479b96270c9f7425d912f540e9b /cmake/examples/dynamic/CMakeLists.txt
parentfix .clang-format (diff)
downloadcmake-common-99eb9822b4dfa67f65674eac92f1371dc4be9d31.tar.gz
cmake-common-99eb9822b4dfa67f65674eac92f1371dc4be9d31.zip
support all 4 cmake default configurations
Diffstat (limited to 'cmake/examples/dynamic/CMakeLists.txt')
-rw-r--r--cmake/examples/dynamic/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/cmake/examples/dynamic/CMakeLists.txt b/cmake/examples/dynamic/CMakeLists.txt
index 1a602d6..4602adb 100644
--- a/cmake/examples/dynamic/CMakeLists.txt
+++ b/cmake/examples/dynamic/CMakeLists.txt
@@ -11,3 +11,6 @@ add_executable(foo foo.cpp)
target_link_libraries(foo PRIVATE baz)
install(TARGETS foo baz RUNTIME DESTINATION bin LIBRARY DESTINATION lib)
+if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
+ install(FILES "$<TARGET_PDB_FILE:foo>" "$<TARGET_PDB_FILE:baz>" DESTINATION bin OPTIONAL)
+endif()