aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/cmake/examples/simple/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-01-17 23:53:16 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2020-01-18 00:16:22 +0300
commit99eb9822b4dfa67f65674eac92f1371dc4be9d31 (patch)
tree47fc1f817c805479b96270c9f7425d912f540e9b /cmake/examples/simple/CMakeLists.txt
parentfix .clang-format (diff)
downloadcmake-common-99eb9822b4dfa67f65674eac92f1371dc4be9d31.tar.gz
cmake-common-99eb9822b4dfa67f65674eac92f1371dc4be9d31.zip
support all 4 cmake default configurations
Diffstat (limited to '')
-rw-r--r--cmake/examples/simple/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/cmake/examples/simple/CMakeLists.txt b/cmake/examples/simple/CMakeLists.txt
index 5f42914..4f8859e 100644
--- a/cmake/examples/simple/CMakeLists.txt
+++ b/cmake/examples/simple/CMakeLists.txt
@@ -7,3 +7,6 @@ include(../../common.cmake)
add_executable(foo foo.cpp)
install(TARGETS foo RUNTIME DESTINATION bin)
+if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
+ install(FILES "$<TARGET_PDB_FILE:foo>" DESTINATION bin OPTIONAL)
+endif()