aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/examples/static/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-03-28 17:19:43 +0000
committerEgor Tensin <Egor.Tensin@gmail.com>2020-03-28 17:23:15 +0000
commit70da99e4f70845da37ae368c4788ecc18546792d (patch)
tree51f50290e2ea926350c88fa5fa0e8d4d2ad426fa /examples/static/CMakeLists.txt
parentcommon.cmake: account for ALIAS targets (diff)
downloadcmake-common-70da99e4f70845da37ae368c4788ecc18546792d.tar.gz
cmake-common-70da99e4f70845da37ae368c4788ecc18546792d.zip
WIP: restructure
A stupid attempt to reduce code duplication led me to believe that all the scripts could use _a bit_ of refactoring. This is going to be a major pain (factoring out all the things), which I'll take gladly. All the links and usage examples are broken right now, but nobody cares, so whatevs.
Diffstat (limited to 'examples/static/CMakeLists.txt')
-rw-r--r--examples/static/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/examples/static/CMakeLists.txt b/examples/static/CMakeLists.txt
new file mode 100644
index 0000000..8a6acb8
--- /dev/null
+++ b/examples/static/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required(VERSION 3.1)
+
+project(example_static)
+
+include(../../common.cmake)
+
+add_library(bar bar.cpp)
+target_include_directories(bar PUBLIC .)
+
+add_executable(foo foo.cpp)
+target_link_libraries(foo PRIVATE bar)
+
+install(TARGETS foo bar RUNTIME DESTINATION bin ARCHIVE DESTINATION lib)
+if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
+ install(FILES "$<TARGET_PDB_FILE:foo>" DESTINATION bin OPTIONAL)
+endif()