aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/cmake/examples/boost/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'cmake/examples/boost/CMakeLists.txt')
-rw-r--r--cmake/examples/boost/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/cmake/examples/boost/CMakeLists.txt b/cmake/examples/boost/CMakeLists.txt
new file mode 100644
index 0000000..87fcc4e
--- /dev/null
+++ b/cmake/examples/boost/CMakeLists.txt
@@ -0,0 +1,11 @@
+cmake_minimum_required(VERSION 3.5) # for Boost::* imported targets
+
+project(example_boost)
+
+include(../../common.cmake)
+
+find_package(Boost REQUIRED COMPONENTS filesystem)
+add_executable(foo foo.cpp)
+target_link_libraries(foo PRIVATE Boost::filesystem)
+
+install(TARGETS foo RUNTIME DESTINATION bin)