aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/cmake/examples/dynamic/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'cmake/examples/dynamic/CMakeLists.txt')
-rw-r--r--cmake/examples/dynamic/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/cmake/examples/dynamic/CMakeLists.txt b/cmake/examples/dynamic/CMakeLists.txt
index 1a602d6..4602adb 100644
--- a/cmake/examples/dynamic/CMakeLists.txt
+++ b/cmake/examples/dynamic/CMakeLists.txt
@@ -11,3 +11,6 @@ add_executable(foo foo.cpp)
target_link_libraries(foo PRIVATE baz)
install(TARGETS foo baz RUNTIME DESTINATION bin LIBRARY DESTINATION lib)
+if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
+ install(FILES "$<TARGET_PDB_FILE:foo>" "$<TARGET_PDB_FILE:baz>" DESTINATION bin OPTIONAL)
+endif()