aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/cmake/examples/dynamic/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'cmake/examples/dynamic/CMakeLists.txt')
-rw-r--r--cmake/examples/dynamic/CMakeLists.txt16
1 files changed, 0 insertions, 16 deletions
diff --git a/cmake/examples/dynamic/CMakeLists.txt b/cmake/examples/dynamic/CMakeLists.txt
deleted file mode 100644
index 4602adb..0000000
--- a/cmake/examples/dynamic/CMakeLists.txt
+++ /dev/null
@@ -1,16 +0,0 @@
-cmake_minimum_required(VERSION 3.1)
-
-project(example_dynamic)
-
-include(../../common.cmake)
-
-add_library(baz SHARED baz.cpp)
-target_include_directories(baz PUBLIC .)
-
-add_executable(foo foo.cpp)
-target_link_libraries(foo PRIVATE baz)
-
-install(TARGETS foo baz RUNTIME DESTINATION bin LIBRARY DESTINATION lib)
-if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
- install(FILES "$<TARGET_PDB_FILE:foo>" "$<TARGET_PDB_FILE:baz>" DESTINATION bin OPTIONAL)
-endif()