aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/cmake/examples/dynamic/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'cmake/examples/dynamic/CMakeLists.txt')
-rw-r--r--cmake/examples/dynamic/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/cmake/examples/dynamic/CMakeLists.txt b/cmake/examples/dynamic/CMakeLists.txt
new file mode 100644
index 0000000..013cde1
--- /dev/null
+++ b/cmake/examples/dynamic/CMakeLists.txt
@@ -0,0 +1,13 @@
+cmake_minimum_required(VERSION 3.1)
+
+project(example_dynamic)
+
+include(../../common.cmake)
+
+add_library(bar SHARED bar.cpp)
+target_include_directories(bar PUBLIC .)
+
+add_executable(foo foo.cpp)
+target_link_libraries(foo PRIVATE bar)
+
+install(TARGETS foo bar RUNTIME DESTINATION bin LIBRARY DESTINATION lib)