aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/cmake/examples/static/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'cmake/examples/static/CMakeLists.txt')
-rw-r--r--cmake/examples/static/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/cmake/examples/static/CMakeLists.txt b/cmake/examples/static/CMakeLists.txt
index 5b76e22..8a6acb8 100644
--- a/cmake/examples/static/CMakeLists.txt
+++ b/cmake/examples/static/CMakeLists.txt
@@ -11,3 +11,6 @@ add_executable(foo foo.cpp)
target_link_libraries(foo PRIVATE bar)
install(TARGETS foo bar RUNTIME DESTINATION bin ARCHIVE DESTINATION lib)
+if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
+ install(FILES "$<TARGET_PDB_FILE:foo>" DESTINATION bin OPTIONAL)
+endif()