aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/examples/boost/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/boost/CMakeLists.txt')
-rw-r--r--examples/boost/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/examples/boost/CMakeLists.txt b/examples/boost/CMakeLists.txt
new file mode 100644
index 0000000..8c076c9
--- /dev/null
+++ b/examples/boost/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required(VERSION 3.5) # for Boost::* imported targets
+
+project(example_boost)
+
+include(../../common.cmake)
+
+find_package(Boost REQUIRED COMPONENTS filesystem)
+add_executable(foo foo.cpp)
+target_link_libraries(foo PRIVATE Boost::disable_autolinking Boost::filesystem)
+
+install(TARGETS foo RUNTIME DESTINATION bin)
+if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
+ install(FILES "$<TARGET_PDB_FILE:foo>" DESTINATION bin OPTIONAL)
+endif()