aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/examples/dynamic/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/dynamic/CMakeLists.txt')
-rw-r--r--examples/dynamic/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/examples/dynamic/CMakeLists.txt b/examples/dynamic/CMakeLists.txt
new file mode 100644
index 0000000..4602adb
--- /dev/null
+++ b/examples/dynamic/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required(VERSION 3.1)
+
+project(example_dynamic)
+
+include(../../common.cmake)
+
+add_library(baz SHARED baz.cpp)
+target_include_directories(baz PUBLIC .)
+
+add_executable(foo foo.cpp)
+target_link_libraries(foo PRIVATE baz)
+
+install(TARGETS foo baz RUNTIME DESTINATION bin LIBRARY DESTINATION lib)
+if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
+ install(FILES "$<TARGET_PDB_FILE:foo>" "$<TARGET_PDB_FILE:baz>" DESTINATION bin OPTIONAL)
+endif()