aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/examples/simple/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/simple/CMakeLists.txt')
-rw-r--r--examples/simple/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/examples/simple/CMakeLists.txt b/examples/simple/CMakeLists.txt
new file mode 100644
index 0000000..4f8859e
--- /dev/null
+++ b/examples/simple/CMakeLists.txt
@@ -0,0 +1,12 @@
+cmake_minimum_required(VERSION 3.1)
+
+project(example_simple)
+
+include(../../common.cmake)
+
+add_executable(foo foo.cpp)
+
+install(TARGETS foo RUNTIME DESTINATION bin)
+if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
+ install(FILES "$<TARGET_PDB_FILE:foo>" DESTINATION bin OPTIONAL)
+endif()