aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/examples/static/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/static/CMakeLists.txt')
-rw-r--r--examples/static/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/examples/static/CMakeLists.txt b/examples/static/CMakeLists.txt
new file mode 100644
index 0000000..8a6acb8
--- /dev/null
+++ b/examples/static/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required(VERSION 3.1)
+
+project(example_static)
+
+include(../../common.cmake)
+
+add_library(bar bar.cpp)
+target_include_directories(bar PUBLIC .)
+
+add_executable(foo foo.cpp)
+target_link_libraries(foo PRIVATE bar)
+
+install(TARGETS foo bar RUNTIME DESTINATION bin ARCHIVE DESTINATION lib)
+if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
+ install(FILES "$<TARGET_PDB_FILE:foo>" DESTINATION bin OPTIONAL)
+endif()