aboutsummaryrefslogtreecommitdiffstatshomepage
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2022-04-30 00:35:27 +0200
committerEgor Tensin <Egor.Tensin@gmail.com>2022-04-30 00:35:27 +0200
commit475990340ba174546f69eda8919a76bb4b6eca77 (patch)
treedf4f630b36ebacf0a3f371faf311da44ee7520de
parentdebian/Makefile: export NAME and EMAIL (diff)
downloadconfig-links-475990340ba174546f69eda8919a76bb4b6eca77.tar.gz
config-links-475990340ba174546f69eda8919a76bb4b6eca77.zip
debian/Makefile: add commit target
-rw-r--r--debian/Makefile6
-rw-r--r--debian/README.Debian4
2 files changed, 9 insertions, 1 deletions
diff --git a/debian/Makefile b/debian/Makefile
index c92c305..c837eda 100644
--- a/debian/Makefile
+++ b/debian/Makefile
@@ -53,6 +53,12 @@ deps:
dch:
gbp dch --distribution=unstable
+.PHONY: commit
+commit:
+ cd -- '$(call escape,$(root))' && \
+ version="$$( dpkg-parsechangelog --show-field Version )" && \
+ git commit -m "debian: $$version"
+
.PHONY: tag
tag:
pushd '$(call escape,$(root))' && gbp buildpackage --git-tag-only
diff --git a/debian/README.Debian b/debian/README.Debian
index d83a5d2..a544b75 100644
--- a/debian/README.Debian
+++ b/debian/README.Debian
@@ -25,8 +25,10 @@ debian/build-area/.
make bin
make bin/test # Ignores uncommmited changes.
- * Tag the last commit in the debian/VERSION format:
+ * Commit the changes:
+ git add changelog
+ make commit
make tag
* Upload the source package to the PPA: