aboutsummaryrefslogtreecommitdiffstatshomepage
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2024-01-28 11:29:05 +0000
committerEgor Tensin <Egor.Tensin@gmail.com>2024-01-28 11:29:05 +0000
commita8cc423c2ed05b953a74efc7beef6e7e68723179 (patch)
tree1f335eadbfc80b3ddd8deffa4728d1d0a81b86d2
parentworkflows: upgrade actions (diff)
parentworkflows/ci: upgrade actions (diff)
downloadconfig-links-a8cc423c2ed05b953a74efc7beef6e7e68723179.tar.gz
config-links-a8cc423c2ed05b953a74efc7beef6e7e68723179.zip
Merge tag 'v2.0.5' into debian
-rw-r--r--.github/workflows/ci.yml4
-rw-r--r--Makefile23
-rw-r--r--prelude.mk23
3 files changed, 27 insertions, 23 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index 2bfb964..f9d3da0 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -14,7 +14,7 @@ jobs:
name: 'Test / ${{ matrix.os }}'
steps:
- name: Checkout
- uses: actions/checkout@v3
+ uses: actions/checkout@v4
- name: Install dependencies
run: |
@@ -37,7 +37,7 @@ jobs:
name: 'Test / Docker / ${{ matrix.distro }}'
steps:
- name: Checkout
- uses: actions/checkout@v3
+ uses: actions/checkout@v4
- name: Test
run: make 'test/docker/${{ matrix.distro }}'
diff --git a/Makefile b/Makefile
index 23de6d3..d713dd2 100644
--- a/Makefile
+++ b/Makefile
@@ -1,24 +1,4 @@
-MAKEFLAGS += --no-builtin-rules --no-builtin-variables --warn-undefined-variables
-unexport MAKEFLAGS
-.DEFAULT_GOAL := all
-.DELETE_ON_ERROR:
-.SUFFIXES:
-SHELL := bash
-.SHELLFLAGS := -eu -o pipefail -c
-
-escape = $(subst ','\'',$(1))
-
-define noexpand
-ifeq ($$(origin $(1)),environment)
- $(1) := $$(value $(1))
-endif
-ifeq ($$(origin $(1)),environment override)
- $(1) := $$(value $(1))
-endif
-ifeq ($$(origin $(1)),command line)
- override $(1) := $$(value $(1))
-endif
-endef
+include prelude.mk
.PHONY: DO
DO:
@@ -36,6 +16,7 @@ test/all: test/local test/docker
test/local:
./test/local/test.sh
+# This is deliberately excluded from test/all, because it quite destructive.
.PHONY: test/linux-home
test/linux-home:
./test/linux-home/test.sh
diff --git a/prelude.mk b/prelude.mk
new file mode 100644
index 0000000..374111e
--- /dev/null
+++ b/prelude.mk
@@ -0,0 +1,23 @@
+# Please see https://egort.name/blog/notes/makefile.html
+
+MAKEFLAGS += --no-builtin-rules --no-builtin-variables --warn-undefined-variables
+unexport MAKEFLAGS
+.DEFAULT_GOAL := all
+.DELETE_ON_ERROR:
+.SUFFIXES:
+SHELL := bash
+.SHELLFLAGS := -eu -o pipefail -c
+
+escape = $(subst ','\'',$(1))
+
+define noexpand
+ifeq ($$(origin $(1)),environment)
+ $(1) := $$(value $(1))
+endif
+ifeq ($$(origin $(1)),environment override)
+ $(1) := $$(value $(1))
+endif
+ifeq ($$(origin $(1)),command line)
+ override $(1) := $$(value $(1))
+endif
+endef