aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/Makefile
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2023-06-30 11:00:41 +0200
committerEgor Tensin <Egor.Tensin@gmail.com>2023-06-30 11:00:41 +0200
commit6220b6dcaa9b4776c6d1d7047aa7c87049f9bb03 (patch)
tree2f56d877c869c8c798ebba065eaa256a666df8a6 /Makefile
parentMakefile: add a comment (diff)
downloadconfig-links-6220b6dcaa9b4776c6d1d7047aa7c87049f9bb03.tar.gz
config-links-6220b6dcaa9b4776c6d1d7047aa7c87049f9bb03.zip
Makefile: move the prelude to prelude.mk
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile22
1 files changed, 1 insertions, 21 deletions
diff --git a/Makefile b/Makefile
index 22da0ca..d713dd2 100644
--- a/Makefile
+++ b/Makefile
@@ -1,24 +1,4 @@
-MAKEFLAGS += --no-builtin-rules --no-builtin-variables --warn-undefined-variables
-unexport MAKEFLAGS
-.DEFAULT_GOAL := all
-.DELETE_ON_ERROR:
-.SUFFIXES:
-SHELL := bash
-.SHELLFLAGS := -eu -o pipefail -c
-
-escape = $(subst ','\'',$(1))
-
-define noexpand
-ifeq ($$(origin $(1)),environment)
- $(1) := $$(value $(1))
-endif
-ifeq ($$(origin $(1)),environment override)
- $(1) := $$(value $(1))
-endif
-ifeq ($$(origin $(1)),command line)
- override $(1) := $$(value $(1))
-endif
-endef
+include prelude.mk
.PHONY: DO
DO: