aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/debian
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2021-04-28 21:31:54 +0000
committerEgor Tensin <Egor.Tensin@gmail.com>2021-04-29 01:42:02 +0300
commit44001e1f1fb81601827b8212f81f5b1760ae9231 (patch)
treede9204b6191fb05592f43015989f4bcaaef13d75 /debian
parentREADME update (diff)
downloadconfig-links-44001e1f1fb81601827b8212f81f5b1760ae9231.tar.gz
config-links-44001e1f1fb81601827b8212f81f5b1760ae9231.zip
add Debian packaging filesdebian/v0.1-1
Basically copied them from my other project linux-status.
Diffstat (limited to 'debian')
-rw-r--r--debian/.gitignore2
-rw-r--r--debian/Makefile93
-rw-r--r--debian/README.Debian44
-rw-r--r--debian/Vagrantfile84
-rw-r--r--debian/changelog5
-rw-r--r--debian/control14
-rw-r--r--debian/copyright31
-rw-r--r--debian/gbp.conf7
-rw-r--r--debian/install7
-rw-r--r--debian/links2
-rwxr-xr-xdebian/rules3
-rw-r--r--debian/source/format1
12 files changed, 293 insertions, 0 deletions
diff --git a/debian/.gitignore b/debian/.gitignore
new file mode 100644
index 0000000..3eb2fb2
--- /dev/null
+++ b/debian/.gitignore
@@ -0,0 +1,2 @@
+build-area/
+.vagrant/
diff --git a/debian/Makefile b/debian/Makefile
new file mode 100644
index 0000000..4ea98d5
--- /dev/null
+++ b/debian/Makefile
@@ -0,0 +1,93 @@
+MAKEFLAGS += --no-builtin-rules --no-builtin-variables --warn-undefined-variables
+unexport MAKEFLAGS
+.DEFAULT_GOAL := all
+.DELETE_ON_ERROR:
+.SUFFIXES:
+SHELL := bash
+# Careful: nounset breaks things, as per usual.
+.SHELLFLAGS := -e -o pipefail -c
+
+.PHONY: DO
+DO:
+
+escape = $(subst ','\'',$(1))
+
+define noexpand
+ifeq ($$(origin $(1)),environment)
+ $(1) := $$(value $(1))
+endif
+ifeq ($$(origin $(1)),environment override)
+ $(1) := $$(value $(1))
+endif
+ifeq ($$(origin $(1)),command line)
+ override $(1) := $$(value $(1))
+endif
+endef
+
+PPA_OWNER ?= egor-tensin
+PPA_NAME ?= config-links
+GPG_KEY ?= 3B3EF1235420917E0DB0723991D679FB92B036CB
+DIST ?= bionic
+
+$(eval $(call noexpand,PPA_OWNER))
+$(eval $(call noexpand,PPA_NAME))
+$(eval $(call noexpand,GPG_KEY))
+$(eval $(call noexpand,DIST))
+
+this_dir := $(dir $(realpath $(firstword $(MAKEFILE_LIST))))
+root := $(this_dir)/..
+build_area := $(this_dir)/build-area
+
+.PHONY: deps
+deps:
+ apt-get update
+ apt-get install -y build-essential devscripts dh-make git-buildpackage
+
+.PHONY: dch
+dch:
+ gbp dch --distribution=unstable
+
+.PHONY: tag
+tag:
+ pushd '$(call escape,$(root))' && gbp buildpackage --git-tag-only
+
+.PHONY: src/test
+src/test:
+ pushd '$(call escape,$(root))' && gbp buildpackage --git-ignore-new -S -us -uc
+
+.PHONY: src
+src:
+ pushd '$(call escape,$(root))' && gbp buildpackage -S '-k0x$(call escape,$(GPG_KEY))'
+
+.PHONY: bin/test
+bin/test:
+ pushd '$(call escape,$(root))' && gbp buildpackage --git-ignore-new -b -us -uc
+
+.PHONY: bin
+bin:
+ pushd '$(call escape,$(root))' && gbp buildpackage -b '-k0x$(call escape,$(GPG_KEY))'
+
+.PHONY: dist/create
+dist/create:
+ pushd '$(call escape,$(root))' && env 'DIST=$(call escape,$(DIST))' git-pbuilder create
+
+.PHONY: dist/update
+dist/update:
+ pushd '$(call escape,$(root))' && env 'DIST=$(call escape,$(DIST))' git-pbuilder update
+
+.PHONY: dist/test
+dist/test:
+ pushd '$(call escape,$(root))' && gbp buildpackage --git-ignore-new --git-pbuilder '--git-dist=$(call escape,$(DIST))'
+
+.PHONY: dist
+dist:
+ pushd '$(call escape,$(root))' && gbp buildpackage --git-pbuilder '--git-dist=$(call escape,$(DIST))'
+ pushd '$(call escape,$(root))' && debsign '-k0x$(call escape,$(GPG_KEY))' --debs-dir '$(call escape,$(build_area))'
+
+.PHONY: upload
+upload:
+ find '$(call escape,$(build_area))' -type f -name '*.changes' -exec dput 'ppa:$(call escape,$(PPA_OWNER))/$(call escape,$(PPA_NAME))/ubuntu/$(DIST)' {} ';'
+
+.PHONY: clean
+clean:
+ rm -rf -- '$(call escape,$(build_area))'
diff --git a/debian/README.Debian b/debian/README.Debian
new file mode 100644
index 0000000..e70c2f8
--- /dev/null
+++ b/debian/README.Debian
@@ -0,0 +1,44 @@
+config-links for Debian
+----------------------
+
+There's a Vagrantfile to make maintenance easier. To start, use `vagrant up`,
+then `vagrant ssh`.
+
+There're a bunch of useful one-liners in Makefile. Everything is built in
+debian/build-area/.
+
+ * Make a source package:
+
+ make src
+ make src/test # Ignores uncommitted changes.
+
+ * Make a binary package:
+
+ make bin
+ make bin/test # Ignores uncommmited changes.
+
+ * Add a changelog entry (you'll need to fix it manually):
+
+ make dch
+
+ * Tag the last commit:
+
+ make tag
+
+ * Upload the source package to the PPA:
+
+ make upload
+
+ To make the package available for different Ubuntu distributions, copy the
+ package binaries on Launchpad. I dread the day when this becomes
+ impossible.
+
+ * Make a binary package using pbuilder (useful for testing that the package
+ builds on a particular distribution):
+
+ make dist/create DIST=focal
+ make dist/update DIST=focal
+ make dist DIST=focal
+ make dist/test DIST=focal # Ignores uncommitted changes.
+
+ -- Egor Tensin <Egor.Tensin@gmail.com> Wed, 28 Apr 2021 21:14:04 +0000
diff --git a/debian/Vagrantfile b/debian/Vagrantfile
new file mode 100644
index 0000000..ab1decb
--- /dev/null
+++ b/debian/Vagrantfile
@@ -0,0 +1,84 @@
+# -*- mode: ruby -*-
+# vi: set ft=ruby :
+
+NAME = 'Egor Tensin'
+EMAIL = 'Egor.Tensin@gmail.com'
+GPG_KEY = '3B3EF1235420917E0DB0723991D679FB92B036CB'
+UID = Process.euid
+
+Vagrant.configure("2") do |config|
+ config.vm.box = "generic/ubuntu2004"
+
+ # Weirdly enough, VirtualBox's shared folders didn't quite work for me.
+ # gbp buildpackage would just exit with FileExistsError, which doesn't
+ # happen with NFS shares.
+ config.vm.synced_folder "../", "/vagrant", type: "nfs"
+
+ config.vm.provider "libvirt" do |v|
+ v.cpus = 2
+ v.memory = 4096
+ end
+
+ # Working with the git repository:
+ config.vm.provision "shell", privileged: false, inline: <<-SHELL
+#!/usr/bin/env bash
+set -o errexit -o nounset -o pipefail
+git config --global user.name '#{NAME}'
+git config --global user.email '#{EMAIL}'
+ SHELL
+ config.ssh.forward_agent = true
+
+ # Set DEB* environment variables:
+ config.vm.provision "shell", privileged: false, inline: <<-SHELL
+#!/usr/bin/env bash
+set -o errexit -o nounset -o pipefail
+tee -a ~/.bashrc <<'EOF'
+export DEBFULLNAME='#{NAME}'
+export DEBEMAIL='#{EMAIL}'
+EOF
+ SHELL
+
+ # gpg-agent forwarding (https://wiki.gnupg.org/AgentForwarding):
+ config.vm.provision "shell", privileged: false, inline: <<-SHELL
+#!/usr/bin/env bash
+set -o errexit -o nounset -o pipefail
+gpg --keyserver hkp://keyserver.ubuntu.com/ --recv-keys '0x#{GPG_KEY}'
+gpg --import-ownertrust <<'EOF'
+#{GPG_KEY}:6:
+EOF
+ SHELL
+ config.vm.provision "shell", inline: <<-SHELL
+#!/usr/bin/env bash
+set -o errexit -o nounset -o pipefail
+echo 'StreamLocalBindUnlink yes' >> /etc/ssh/sshd_config
+ SHELL
+ # "agent-extra-socket" on the host.
+ local_gpg_socket = one_line(run('gpgconf', '--list-dirs', 'agent-extra-socket'))
+ # "agent-socket" on the VM.
+ remote_gpg_socket = "/run/user/#{UID}/gnupg/S.gpg-agent"
+ config.ssh.extra_args = ['-R', "#{remote_gpg_socket}:#{local_gpg_socket}"]
+
+ # Install the required packages:
+ config.vm.provision "shell", inline: <<-SHELL
+#!/usr/bin/env bash
+set -o errexit -o nounset -o pipefail
+apt-get update && apt-get install -y make
+cd /vagrant/debian && make deps
+ SHELL
+
+ config.vm.provision :reload
+end
+
+require "open3"
+
+def run(*cmd)
+ stdout, stderr, status = Open3.capture3(*cmd)
+ abort stderr unless status.success?
+ stdout
+end
+
+def one_line(output)
+ lines = output.lines.map(&:chomp)
+ abort "Must be a single line: #{lines}" unless lines.length == 1
+ lines.first
+end
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..37282d4
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+config-links (0.1-1) unstable; urgency=medium
+
+ * Initial release.
+
+ -- Egor Tensin <Egor.Tensin@gmail.com> Wed, 28 Apr 2021 21:14:04 +0000
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..95a2475
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,14 @@
+Source: config-links
+Section: utils
+Priority: optional
+Maintainer: Egor Tensin <Egor.Tensin@gmail.com>
+Build-Depends: debhelper-compat (= 10)
+Standards-Version: 4.4.1
+Homepage: https://github.com/egor-tensin/config-links
+
+Package: config-links
+Architecture: all
+Depends: bash, ${misc:Depends}
+Description: Configuration file sharing
+ Store your files in a repository, checkout it on any machine, and easily
+ create & maintain symlinks to all of them.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..6fd52f2
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,31 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: config-links
+Upstream-Contact: Egor Tensin <Egor.Tensin@gmail.com>
+Source: https://github.com/egor-tensin/config-links
+
+Files: *
+Copyright: 2016-2021 Egor Tensin <Egor.Tensin@gmail.com>
+License: MIT
+
+Files: debian/*
+Copyright: 2021 Egor Tensin <Egor.Tensin@gmail.com>
+License: MIT
+
+License: MIT
+ Permission is hereby granted, free of charge, to any person obtaining a
+ copy of this software and associated documentation files (the "Software"),
+ to deal in the Software without restriction, including without limitation
+ the rights to use, copy, modify, merge, publish, distribute, sublicense,
+ and/or sell copies of the Software, and to permit persons to whom the
+ Software is furnished to do so, subject to the following conditions:
+ .
+ The above copyright notice and this permission notice shall be included
+ in all copies or substantial portions of the Software.
+ .
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+ OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+ MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+ IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+ CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+ TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+ SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/debian/gbp.conf b/debian/gbp.conf
new file mode 100644
index 0000000..e7faaa2
--- /dev/null
+++ b/debian/gbp.conf
@@ -0,0 +1,7 @@
+[DEFAULT]
+upstream-tag = v%(version)s
+ignore-branch = True
+debian-branch = debian
+debian-tag = debian/v%(version)s
+pristine-tar = False
+export-dir = debian/build-area/
diff --git a/debian/install b/debian/install
new file mode 100644
index 0000000..f47c0b7
--- /dev/null
+++ b/debian/install
@@ -0,0 +1,7 @@
+LICENSE.txt usr/share/config-links
+
+README.md usr/share/doc/config-links
+
+update.sh usr/lib/config-links
+unlink.sh usr/lib/config-links
+src usr/lib/config-links
diff --git a/debian/links b/debian/links
new file mode 100644
index 0000000..db3af36
--- /dev/null
+++ b/debian/links
@@ -0,0 +1,2 @@
+usr/lib/config-links/update.sh usr/bin/links-update
+usr/lib/config-links/unlink.sh usr/bin/links-remove
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..cbe925d
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,3 @@
+#!/usr/bin/make -f
+%:
+ dh $@
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)