aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/debian
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2022-04-30 00:34:27 +0200
committerEgor Tensin <Egor.Tensin@gmail.com>2022-04-30 00:34:27 +0200
commit8fdfc3dbb03d8a472b53eac0a4f8c4834625bfff (patch)
treea2d8ef15e586b9ca952210d3b8e6d04f6f5343a4 /debian
parentdebian: 2.0.1-2 (diff)
downloadconfig-links-8fdfc3dbb03d8a472b53eac0a4f8c4834625bfff.tar.gz
config-links-8fdfc3dbb03d8a472b53eac0a4f8c4834625bfff.zip
debian/Makefile: export NAME and EMAIL
I'm trying to build packages locally on my Arch, and I don't want to add these variables to my .bashrc.
Diffstat (limited to 'debian')
-rw-r--r--debian/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/Makefile b/debian/Makefile
index cd8dc36..c92c305 100644
--- a/debian/Makefile
+++ b/debian/Makefile
@@ -20,16 +20,23 @@ ifeq ($$(origin $(1)),command line)
endif
endef
+NAME ?= Egor Tensin
+EMAIL ?= Egor.Tensin@gmail.com
PPA_OWNER ?= egor-tensin
PPA_NAME ?= config-links
GPG_KEY ?= 3B3EF1235420917E0DB0723991D679FB92B036CB
DIST ?= bionic
+$(eval $(call noexpand,NAME))
+$(eval $(call noexpand,EMAIL))
$(eval $(call noexpand,PPA_OWNER))
$(eval $(call noexpand,PPA_NAME))
$(eval $(call noexpand,GPG_KEY))
$(eval $(call noexpand,DIST))
+export NAME
+export EMAIL
+
this_dir := $(dir $(realpath $(firstword $(MAKEFILE_LIST))))
root := $(this_dir)/..
build_area := $(this_dir)/build-area