aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/debian
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2022-04-06 10:18:30 +0200
committerEgor Tensin <Egor.Tensin@gmail.com>2022-04-06 10:22:11 +0200
commit510da7cd74be5cae4994f13d2c0c51001f75d815 (patch)
tree66b983d87336832248be663c1912eb9ee7a7132e /debian
parentdebian/README: rearrange items (diff)
downloadconfig-links-510da7cd74be5cae4994f13d2c0c51001f75d815.tar.gz
config-links-510da7cd74be5cae4994f13d2c0c51001f75d815.zip
debian/Makefile: consistent prelude
Diffstat (limited to 'debian')
-rw-r--r--debian/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/debian/Makefile b/debian/Makefile
index a898ba3..cd8dc36 100644
--- a/debian/Makefile
+++ b/debian/Makefile
@@ -4,11 +4,7 @@ unexport MAKEFLAGS
.DELETE_ON_ERROR:
.SUFFIXES:
SHELL := bash
-# Careful: nounset breaks things, as per usual.
-.SHELLFLAGS := -e -o pipefail -c
-
-.PHONY: DO
-DO:
+.SHELLFLAGS := -eu -o pipefail -c
escape = $(subst ','\'',$(1))
@@ -38,6 +34,9 @@ this_dir := $(dir $(realpath $(firstword $(MAKEFILE_LIST))))
root := $(this_dir)/..
build_area := $(this_dir)/build-area
+.PHONY: DO
+DO:
+
.PHONY: deps
deps:
apt-get update