aboutsummaryrefslogtreecommitdiffstatshomepage
diff options
context:
space:
mode:
-rw-r--r--debian/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/debian/Makefile b/debian/Makefile
index a898ba3..cd8dc36 100644
--- a/debian/Makefile
+++ b/debian/Makefile
@@ -4,11 +4,7 @@ unexport MAKEFLAGS
.DELETE_ON_ERROR:
.SUFFIXES:
SHELL := bash
-# Careful: nounset breaks things, as per usual.
-.SHELLFLAGS := -e -o pipefail -c
-
-.PHONY: DO
-DO:
+.SHELLFLAGS := -eu -o pipefail -c
escape = $(subst ','\'',$(1))
@@ -38,6 +34,9 @@ this_dir := $(dir $(realpath $(firstword $(MAKEFILE_LIST))))
root := $(this_dir)/..
build_area := $(this_dir)/build-area
+.PHONY: DO
+DO:
+
.PHONY: deps
deps:
apt-get update