diff options
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 23 |
1 files changed, 2 insertions, 21 deletions
@@ -1,24 +1,4 @@ -MAKEFLAGS += --no-builtin-rules --no-builtin-variables --warn-undefined-variables -unexport MAKEFLAGS -.DEFAULT_GOAL := all -.DELETE_ON_ERROR: -.SUFFIXES: -SHELL := bash -.SHELLFLAGS := -eu -o pipefail -c - -escape = $(subst ','\'',$(1)) - -define noexpand -ifeq ($$(origin $(1)),environment) - $(1) := $$(value $(1)) -endif -ifeq ($$(origin $(1)),environment override) - $(1) := $$(value $(1)) -endif -ifeq ($$(origin $(1)),command line) - override $(1) := $$(value $(1)) -endif -endef +include prelude.mk .PHONY: DO DO: @@ -36,6 +16,7 @@ test/all: test/local test/docker test/local: ./test/local/test.sh +# This is deliberately excluded from test/all, because it quite destructive. .PHONY: test/linux-home test/linux-home: ./test/linux-home/test.sh |