aboutsummaryrefslogtreecommitdiffstatshomepage
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2022-04-29 23:22:01 +0200
committerEgor Tensin <Egor.Tensin@gmail.com>2022-04-29 23:22:01 +0200
commit1830b942af8d58713dda1fc459fc9be388d44528 (patch)
treecd2835dc15542bacfb66506e039254caf6ca20c5
parentaur: 2.2-1 (diff)
downloadlinux-status-1830b942af8d58713dda1fc459fc9be388d44528.tar.gz
linux-status-1830b942af8d58713dda1fc459fc9be388d44528.zip
Makefile: remove tag, add commit
-rw-r--r--Makefile6
-rw-r--r--README.Arch6
2 files changed, 6 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 3308995..b1422cb 100644
--- a/Makefile
+++ b/Makefile
@@ -34,9 +34,9 @@ all: package
package:
makepkg --clean --cleanbuild --force --syncdeps && makepkg --printsrcinfo > '$(call escape,$(this_dir))/.SRCINFO'
-.PHONY: tag
-tag:
- source PKGBUILD && git tag "aur/v$$pkgver-$$pkgrel"
+.PHONY: commit
+commit:
+ source PKGBUILD && git commit -am "aur: $$pkgver-$$pkgrel"
.PHONY: push
push:
diff --git a/README.Arch b/README.Arch
index 2d8787c..f8feeb1 100644
--- a/README.Arch
+++ b/README.Arch
@@ -6,13 +6,13 @@ then `vagrant ssh`.
There're a bunch of useful one-liners in Makefile.
- * Make the package:
+ * Make the package (this also updates .SRCINFO):
make package
- * Tag the last commit:
+ * Commit the changes:
- make tag
+ make commit
* Push to the AUR repository: