aboutsummaryrefslogtreecommitdiffstatshomepage
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2022-04-15 12:08:26 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2022-04-15 12:08:26 +0300
commit4d2bbb4aa8336df22a6ee29862d3c85a49aba874 (patch)
treecdca2b458709caafc51950b6e8035d93298761e1
parentMerge tag 'v2.1.3' into debian (diff)
downloadlinux-status-4d2bbb4aa8336df22a6ee29862d3c85a49aba874.tar.gz
linux-status-4d2bbb4aa8336df22a6ee29862d3c85a49aba874.zip
debian/Makefile: export NAME and EMAIL
I'm trying to build packages locally on my Arch, and I don't want to add these variables to my .bashrc.
-rw-r--r--debian/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/Makefile b/debian/Makefile
index 5f66ce4..82222af 100644
--- a/debian/Makefile
+++ b/debian/Makefile
@@ -20,16 +20,23 @@ ifeq ($$(origin $(1)),command line)
endif
endef
+NAME ?= Egor Tensin
+EMAIL ?= Egor.Tensin@gmail.com
PPA_OWNER ?= egor-tensin
PPA_NAME ?= linux-status
GPG_KEY ?= 3B3EF1235420917E0DB0723991D679FB92B036CB
DIST ?= bionic
+$(eval $(call noexpand,NAME))
+$(eval $(call noexpand,EMAIL))
$(eval $(call noexpand,PPA_OWNER))
$(eval $(call noexpand,PPA_NAME))
$(eval $(call noexpand,GPG_KEY))
$(eval $(call noexpand,DIST))
+export NAME
+export EMAIL
+
this_dir := $(dir $(realpath $(firstword $(MAKEFILE_LIST))))
root := $(this_dir)/..
build_area := $(this_dir)/build-area