aboutsummaryrefslogtreecommitdiffstatshomepage
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2023-02-04 21:50:00 +0100
committerEgor Tensin <Egor.Tensin@gmail.com>2023-02-04 21:50:03 +0100
commit42e8ceffbdbaa774adb218bd7ea26c1efd043de8 (patch)
tree9ab3198e6e4a47cce15d4eaaca59126cb82b8d11
parentdebian/Makefile: install vim as a dependency (diff)
downloadlinux-status-42e8ceffbdbaa774adb218bd7ea26c1efd043de8.tar.gz
linux-status-42e8ceffbdbaa774adb218bd7ea26c1efd043de8.zip
debian: disable build system auto-detection
I've bumped into this while working on my other project (config-links). If you put a Makefile in the root directory, debhelper will assume the project is built using make, which is not what we want. Also, bump the cowbuilder image to Focal, since Bionic's debhelper doesn't seem to support --buildsystem=none.
-rw-r--r--debian/Makefile2
-rwxr-xr-xdebian/rules2
2 files changed, 2 insertions, 2 deletions
diff --git a/debian/Makefile b/debian/Makefile
index c18c921..7f6fc01 100644
--- a/debian/Makefile
+++ b/debian/Makefile
@@ -25,7 +25,7 @@ EMAIL ?= Egor.Tensin@gmail.com
PPA_OWNER ?= egor-tensin
PPA_NAME ?= linux-status
GPG_KEY ?= 3B3EF1235420917E0DB0723991D679FB92B036CB
-DIST ?= bionic
+DIST ?= focal
$(eval $(call noexpand,NAME))
$(eval $(call noexpand,EMAIL))
diff --git a/debian/rules b/debian/rules
index cbe925d..43896d7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,3 +1,3 @@
#!/usr/bin/make -f
%:
- dh $@
+ dh $@ --buildsystem=none