aboutsummaryrefslogtreecommitdiffstatshomepage
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2023-06-30 10:21:23 +0200
committerEgor Tensin <Egor.Tensin@gmail.com>2023-06-30 10:21:23 +0200
commitefa4985ae31d973017cf4d506b560c6fc8a97484 (patch)
tree034a8033ac0d0d5c687ce71691b4fd2255bfe665
parentdebian: 2.3.2-3 (diff)
downloadlinux-status-efa4985ae31d973017cf4d506b560c6fc8a97484.tar.gz
linux-status-efa4985ae31d973017cf4d506b560c6fc8a97484.zip
debian/Makefile: move the prelude to prelude.mk
-rw-r--r--debian/Makefile22
-rw-r--r--debian/prelude.mk23
2 files changed, 24 insertions, 21 deletions
diff --git a/debian/Makefile b/debian/Makefile
index 35df656..922ad28 100644
--- a/debian/Makefile
+++ b/debian/Makefile
@@ -1,24 +1,4 @@
-MAKEFLAGS += --no-builtin-rules --no-builtin-variables --warn-undefined-variables
-unexport MAKEFLAGS
-.DEFAULT_GOAL := all
-.DELETE_ON_ERROR:
-.SUFFIXES:
-SHELL := bash
-.SHELLFLAGS := -eu -o pipefail -c
-
-escape = $(subst ','\'',$(1))
-
-define noexpand
-ifeq ($$(origin $(1)),environment)
- $(1) := $$(value $(1))
-endif
-ifeq ($$(origin $(1)),environment override)
- $(1) := $$(value $(1))
-endif
-ifeq ($$(origin $(1)),command line)
- override $(1) := $$(value $(1))
-endif
-endef
+include prelude.mk
NAME ?= Egor Tensin
EMAIL ?= Egor.Tensin@gmail.com
diff --git a/debian/prelude.mk b/debian/prelude.mk
new file mode 100644
index 0000000..374111e
--- /dev/null
+++ b/debian/prelude.mk
@@ -0,0 +1,23 @@
+# Please see https://egort.name/blog/notes/makefile.html
+
+MAKEFLAGS += --no-builtin-rules --no-builtin-variables --warn-undefined-variables
+unexport MAKEFLAGS
+.DEFAULT_GOAL := all
+.DELETE_ON_ERROR:
+.SUFFIXES:
+SHELL := bash
+.SHELLFLAGS := -eu -o pipefail -c
+
+escape = $(subst ','\'',$(1))
+
+define noexpand
+ifeq ($$(origin $(1)),environment)
+ $(1) := $$(value $(1))
+endif
+ifeq ($$(origin $(1)),environment override)
+ $(1) := $$(value $(1))
+endif
+ifeq ($$(origin $(1)),command line)
+ override $(1) := $$(value $(1))
+endif
+endef