aboutsummaryrefslogtreecommitdiffstatshomepage
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2022-04-30 00:05:12 +0200
committerEgor Tensin <Egor.Tensin@gmail.com>2022-04-30 00:05:12 +0200
commit2b09d905e1036ce63ac7f0e5417b973a01b37550 (patch)
treea6823846b4a5b0d7675bdc1db8b51a8fcb851be7
parentdebian: 2.2-1 (diff)
downloadlinux-status-2b09d905e1036ce63ac7f0e5417b973a01b37550.tar.gz
linux-status-2b09d905e1036ce63ac7f0e5417b973a01b37550.zip
debian/Makefile: add commit target
-rw-r--r--debian/Makefile6
-rw-r--r--debian/README.Debian4
2 files changed, 9 insertions, 1 deletions
diff --git a/debian/Makefile b/debian/Makefile
index 82222af..a145c53 100644
--- a/debian/Makefile
+++ b/debian/Makefile
@@ -53,6 +53,12 @@ deps:
dch:
gbp dch --distribution=unstable
+.PHONY: commit
+commit:
+ cd -- '$(call escape,$(root))' && \
+ version="$$( dpkg-parsechangelog --show-field Version )" && \
+ git commit -m "debian: $$version"
+
.PHONY: tag
tag:
pushd '$(call escape,$(root))' && gbp buildpackage --git-tag-only
diff --git a/debian/README.Debian b/debian/README.Debian
index d9005cf..83a663b 100644
--- a/debian/README.Debian
+++ b/debian/README.Debian
@@ -25,8 +25,10 @@ debian/build-area/.
make bin
make bin/test # Ignores uncommmited changes.
- * Tag the last commit in the debian/VERSION format:
+ * Commit the changes:
+ git add changelog
+ make commit
make tag
* Upload the source package to the PPA: