aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/Makefile
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2023-06-30 11:04:03 +0200
committerEgor Tensin <Egor.Tensin@gmail.com>2023-06-30 11:04:03 +0200
commit10bd230f0507bbcad845a257012abb3d330c7ed1 (patch)
tree65940d8a69e7d4a1b482f1db547d049783020903 /Makefile
parentaur: 2.3.2-1 (diff)
downloadlinux-status-10bd230f0507bbcad845a257012abb3d330c7ed1.tar.gz
linux-status-10bd230f0507bbcad845a257012abb3d330c7ed1.zip
Makefile: move the prelude to prelude.mk
Diffstat (limited to '')
-rw-r--r--Makefile22
1 files changed, 1 insertions, 21 deletions
diff --git a/Makefile b/Makefile
index 7de6642..ebd7074 100644
--- a/Makefile
+++ b/Makefile
@@ -1,24 +1,4 @@
-MAKEFLAGS += --no-builtin-rules --no-builtin-variables --warn-undefined-variables
-unexport MAKEFLAGS
-.DEFAULT_GOAL := all
-.DELETE_ON_ERROR:
-.SUFFIXES:
-SHELL := bash
-.SHELLFLAGS := -eu -o pipefail -c
-
-escape = $(subst ','\'',$(1))
-
-define noexpand
-ifeq ($$(origin $(1)),environment)
- $(1) := $$(value $(1))
-endif
-ifeq ($$(origin $(1)),environment override)
- $(1) := $$(value $(1))
-endif
-ifeq ($$(origin $(1)),command line)
- override $(1) := $$(value $(1))
-endif
-endef
+include prelude.mk
PKG_NAME := linux-status