diff options
author | Egor Tensin <Egor.Tensin@gmail.com> | 2021-03-31 20:43:30 +0300 |
---|---|---|
committer | Egor Tensin <Egor.Tensin@gmail.com> | 2021-04-07 03:32:17 +0300 |
commit | 5cef42066d6c6ec38e180a95cc98379f4bfea331 (patch) | |
tree | ad2625e9a02c89cada9e93daee8e4b94152b446c /Makefile | |
parent | aur: 1.0-1 (diff) | |
download | linux-status-5cef42066d6c6ec38e180a95cc98379f4bfea331.tar.gz linux-status-5cef42066d6c6ec38e180a95cc98379f4bfea331.zip |
aur: Makefile best practices
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 20 |
1 files changed, 18 insertions, 2 deletions
@@ -1,12 +1,28 @@ -MAKEFLAGS += --warn-undefined-variables +MAKEFLAGS += --no-builtin-rules --no-builtin-variables --warn-undefined-variables +unexport MAKEFLAGS .DEFAULT_GOAL := all .DELETE_ON_ERROR: .SUFFIXES: SHELL := bash -.SHELLFLAGS := -e -o pipefail -c +.SHELLFLAGS := -eu -o pipefail -c + +.PHONY: DO +DO: escape = $(subst ','\'',$(1)) +define noexpand +ifeq ($$(origin $(1)),environment) + $(1) := $$(value $(1)) +endif +ifeq ($$(origin $(1)),environment override) + $(1) := $$(value $(1)) +endif +ifeq ($$(origin $(1)),command line) + override $(1) := $$(value $(1)) +endif +endef + PKG_NAME := linux-status this_dir := $(dir $(realpath $(firstword $(MAKEFILE_LIST)))) |