aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/Makefile
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2021-03-08 12:54:21 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2021-03-08 12:55:56 +0300
commit5dd552d949c03059557f3cc3c6f7a320a0bf9e01 (patch)
treeaba85ca9dc5fef85be8c8f7df923313b6600db92 /Makefile
parentaur: 0.0.2-1 (diff)
downloadlinux-status-5dd552d949c03059557f3cc3c6f7a320a0bf9e01.tar.gz
linux-status-5dd552d949c03059557f3cc3c6f7a320a0bf9e01.zip
aur: add Vagrantfile, Makefile, etc.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..3ba30d0
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,31 @@
+MAKEFLAGS += --warn-undefined-variables
+.DEFAULT_GOAL := all
+.DELETE_ON_ERROR:
+.SUFFIXES:
+SHELL := bash
+.SHELLFLAGS := -e -o pipefail -c
+
+escape = $(subst ','\'',$(1))
+
+PKG_NAME := linux-status
+
+this_dir := $(dir $(realpath $(firstword $(MAKEFILE_LIST))))
+
+.PHONY: all
+all: package
+
+.PHONY: package
+package:
+ makepkg --clean --cleanbuild --force --syncdeps && makepkg --printsrcinfo > '$(call escape,$(this_dir))/.SRCINFO'
+
+.PHONY: tag
+tag:
+ source PKGBUILD && git tag "aur/v$$pkgver-$$pkgrel"
+
+.PHONY: push
+push:
+ git push ssh://aur@aur.archlinux.org/linux-status.git "$$( git symbolic-ref HEAD ):master"
+
+.PHONY: clean
+clean:
+ find '$(call escape,$(this_dir))' -type f '-(' -name '*.tar.gz' -o -name '*.tar.zst' '-)' -delete