aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/debian/Makefile
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2022-04-06 10:31:44 +0200
committerEgor Tensin <Egor.Tensin@gmail.com>2022-04-06 10:31:44 +0200
commit232205fa2342f6611c8bc0e4ca5ca7c2748b41df (patch)
treec2551a5970dcd0d10a6e49508406fbe797335a26 /debian/Makefile
parentdebian/README: rearrange items (diff)
downloadlinux-status-232205fa2342f6611c8bc0e4ca5ca7c2748b41df.tar.gz
linux-status-232205fa2342f6611c8bc0e4ca5ca7c2748b41df.zip
debian/Makefile: consistent prelude
Diffstat (limited to '')
-rw-r--r--debian/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/debian/Makefile b/debian/Makefile
index c048207..5f66ce4 100644
--- a/debian/Makefile
+++ b/debian/Makefile
@@ -4,11 +4,7 @@ unexport MAKEFLAGS
.DELETE_ON_ERROR:
.SUFFIXES:
SHELL := bash
-# Careful: nounset breaks things, as per usual.
-.SHELLFLAGS := -e -o pipefail -c
-
-.PHONY: DO
-DO:
+.SHELLFLAGS := -eu -o pipefail -c
escape = $(subst ','\'',$(1))
@@ -38,6 +34,9 @@ this_dir := $(dir $(realpath $(firstword $(MAKEFILE_LIST))))
root := $(this_dir)/..
build_area := $(this_dir)/build-area
+.PHONY: DO
+DO:
+
.PHONY: deps
deps:
apt-get update