aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/debian/Makefile
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2021-03-06 19:51:23 +0000
committerEgor Tensin <Egor.Tensin@gmail.com>2021-03-07 01:21:11 +0000
commit8d2ac98d53c2cc5fef05974bc9e58b5b72331259 (patch)
tree6b9e858f00553b17ffac5a1c253a9b7c4823ee7d /debian/Makefile
parentexport pacman packaging to a separate branch (diff)
downloadlinux-status-8d2ac98d53c2cc5fef05974bc9e58b5b72331259.tar.gz
linux-status-8d2ac98d53c2cc5fef05974bc9e58b5b72331259.zip
add Debian packaging filesdebian/v0.0.1-1
Diffstat (limited to 'debian/Makefile')
-rw-r--r--debian/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/debian/Makefile b/debian/Makefile
new file mode 100644
index 0000000..74a8a18
--- /dev/null
+++ b/debian/Makefile
@@ -0,0 +1,28 @@
+MAKEFLAGS += --warn-undefined-variables
+.DEFAULT_GOAL := all
+.DELETE_ON_ERROR:
+.SUFFIXES:
+SHELL := bash
+.SHELLFLAGS := -e -o pipefail -c
+
+escape = $(subst ','\'',$(1))
+
+makefile_dir := $(dir $(realpath $(firstword $(MAKEFILE_LIST))))
+repo_dir := $(makefile_dir)/..
+build_area_dir := $(makefile_dir)/build-area
+
+.PHONY: build/src
+build/src:
+ pushd '$(call escape,$(repo_dir))' && gbp buildpackage -S
+
+.PHONY: build/bin
+build/bin:
+ pushd '$(call escape,$(repo_dir))' && gbp buildpackage
+
+.PHONY: build/pbuilder
+build/pbuilder:
+ pushd '$(call escape,$(repo_dir))' && gbp buildpackage --git-pbuilder --git-dist=focal --git-arch=amd64
+
+.PHONY: clean
+clean:
+ rm -rf -- '$(call escape,$(build_area_dir))'